Problem accessing M-Files server through local admin too

Hi M-Files and community, 

We have recently tried approach that was recommended for us in this entry some time ago. We have installed Admin and configure it accordingly to connect to our M-Files server. 

My colleague, who is vault and and SysAdmin on M-Files, has tried to connect remotely. The connection seems to work and he can see all metadata, workflows etc.

But when he tries to upload changes through his local admin to Admin server, he has experienced following error:

Basically, when he tries to select the package and related Index.xml (please be aware that the whole package is locally on his PC), he is getting strange error related to security:

"For security reasons, you can not browse the disk contents of a remote M-File server". 

Actually, he tries to select the package which is located on his PC using local Admin tool which is connected to our M-Files server. It seems that selection reaches M-Files server instead of local C drive. He also tried to add a full path but it has not worked well.

Is using of Admin tool only limited to be used on M-Files server? Does it mean that all Admins would need to log on on remote server to upload and setup changes and could not use local installed Admins configured to connect to remote M-Files server?

Could someone clarify the usage of Admin tool and what is usual usage? It would be pity that we would need to connect remotely to M-Files server to upload configurations.

Thanks for your experiences.

Dejan