Error when copy/pasting a file

Hi everyone,

When I copy/paste a file, the folllowing error is raised (sorry it's in french)

MItemsCreator.cpp, 538, La création de l'objet a échoué. (0x80040419)
MItemsCreator.cpp, 709, La création de l'objet a échoué. (0x80040419)
MItemsCreator.cpp, 1102, La création de l'objet a échoué. (0x80040419)
MItemsCreator.cpp, 1102, Paramètre incorrect. (Caractères non conformes dans le chemin d'accès.) (0x80070057)
MItemsCreator.cpp, 1517, Paramètre incorrect. (Caractères non conformes dans le chemin d'accès.) (0x80070057)
ShellDataTransferThread.cpp, 722, Paramètre incorrect. (Caractères non conformes dans le chemin d'accès.) (0x80070057)
CoFileInformation.cpp, 122, Paramètre incorrect. (Caractères non conformes dans le chemin d'accès.) (0x80070057)

The error appear before the file is even created.

Copying the file outside M-Files and back in works

Error is encounter by everyone so I would say it's file specific but I d'ont know where to search more information

Thank you, Jessica

  • The error message mentions "Illegal characters in path"
    The problem probably occurs when M-Files tries to place a temporary file copy on the server in a Temp path. If the document name has special characters in it M-Files may attempt to use those characters in the temp path.
    If this error comes on all copy/paste operations there must be some misconfiguration on your server.
    If the error only comes on certain files with special characters in the file or document name you might want to change those characters in the name.
    I seem to remember a setting somewhere which will allow M-Files to replace special characters with something that won't cause problems. Can't remember exactly where that is, sorry.

  • OK thank you for your answer.

    I search for windows illegal charaters and none of them are in the file name (everything is in capital and the only character is "-"). Does M-Files have more illegal characters?

    Moreover if copying outside then back inside shouldn't the error appear again ?

    It is specific to only this one particular file, no others

    If you remember the setting feel free to add the solution here Slight smile

    Best regards, Jessica