Co-Authoring Not Saving the Files

When a document is checked out for co-authoring, and then checked back in, it will not save the changes, even if I click the end co-authoring button on the office 365 site. This only happens to certain documents, not all of the files have this issue. It's mostly Excel documents.

Parents
  • Hi there, 

    I recall such issue at our support system. There is a "lag" at the saving. Eventually those should be saved. The issue is at Office Online side which has quite a long lantecies in some situations. Does it help, if you add some "wait time for the Office to save things? 

    (I may have a wrong clue here, this is straight from the memory lane) 

  • Hi Timo

    I did test this, I waited about some time, it does say, "Saved" on office 365 online, but it did not save. This does not happen to all files, but they are the same .xlsx file type.  This only happens after checking in the document, if I open back up without checking in, the changes will still be there, but after checking in and checking back out, the changes will be gone.

  • Hi Moises, 

    With these XLSX files, do you know if any of these have any macros or objects embedded into any of the sheets? Can you determine if there is something different with the XLSX files that work compared to the ones that do not?

  • Hello Sean,

    They do not have any difference that I can spot on. No Macros either. 

    The files I have issues with, I was able to work with them properly using one drive. I open them from OneDrive, then it goes to Office Online, make a change, close the tab, go back and re-open, the file has the changes. Opposed to Co-Authoring on M-Files.

    I have also tried this using the MS Teams App on desktop (Teams has One Drive Integration which allows it to co-author files on the web just like M-Files Does), We used co-authoring with a coworker and it worked as expected as well.

    Another thing that I should point out is that when I open a file for Co-Authoring, then without checking in someone else opens the file, the changes I have made are there when they open the file with co-authoring. It is only when I check in that the changes are lost.

    Any other idea of what could be causing M-Files to not receive the changes.

    Thanks again for reaching out.

  • Hi Moises, 

    Very strange behavior. Please submit a ticket to M-Files support with these details. 

    Many Thanks!

Reply Children
No Data