How to delete removed mapping property from object type?

Hi M-Files and community, 

We have stumbled on an issue that we can not delete property of already imported object type entries in M-Files. 

We have wrongly mapped one of metadata into our object type, we mapped it into wrong column and import data for object types from SQL Server DB. So there specific versions of that object types in M-Files. 

After that we have removed the mapping to that wrong metadata from object type mapping and have updated our select statement. When we have refreshed object type with in M-Files Client, we have an option to delete metadata which is not mapped any more.

Unfortunately, this throws an error attached.


I have also tried to delete whole object type and start from scratch. But this seems not to be possible as well and it recommends first to delete imported objects (objects are imported from DB actually and we can not delete them in original DB so we have read-only object types).

So my question is how to solve this problem? How to remove those dead not mapped properties? Or how can I remove whole object type?

Thanks for suggestions and best practices.


  • Hi Dejan,

    Have you tried disabling the external connection?  Without the external connection active you should be able to remove the desired content.  Once it has been removed you can reenable the connection string.

    I hope this helps, if you need additional assistance let me know and we can set up a working session.

  • Thanks Tom, we have end up creating temp empty table and bound it with object type, containing no entries. After that we have drop object type with wrong mappings and created a new one. 

    Your approach is probably even easier but we have missed it.


Reply Children